T.I. MATRICULATION HIGHER SECONDARY SCHOOL, AMBATTUR
HALF YEARLY EXAMINATION - 2018
Class XI Computer Science -Commerce Group Scoring Key
MARKS: 70
I

Choose the best answer

15 x 1 = 15

1.________________ is an output device that is used to produce graphical output on paper using
single color or multi color pens to draw pictures.
a) OCR

b) Plotter

c) Laser printer

d) Dot matrix printer

2.1101010112=?10,?16,?8?
a) 42710,1AB16,6538

b) 43710,1101116,6538 c) 42010,1B16,638

d) 43310,1AB16,6538

3. To connect the hard disk drives and network connectors _______ port is used.
a) Parallel

b)VGA connector

c) PS/2

d) SCSI

4.The Linux operating system was originated in _____________ as a project of ________ ,
university student of Finland?
a) 1991, Linus Torvalds

b) 1989, Linus Torvalds

c) 1897, Dennis Ritchie

d) 1821, Ken Thompson

5._____________ option found only on laptop computers puts the computer in a low power mode
after saving all running programs and opens windows on the machine‟s hard drive for a quick
restart.
a) Switch user

b) Lock

c) Sleep

d) Hibernate

6.Ubuntu was conceived in 2004 by _________________________ a successful South African
entrepreneur.
a) Mark Shuttleworth

b) G Polya

c) E W Dijkstra

d) Edward Jenner

7.By clicking on _________________ icon, document preparation application in Ubuntu could be
opened
a) Libre Office Calc

b) Libre Office Impress

c) Libre Office Writer

d) Trash

8.The opening screen of Open Office is called as ______________
a) Star Center

b) Office Center

c) Draw Center

d) Open Office Center

9.The two types of orientation are _____________ and __________________
a)Header, footer

b) Portrait, Landscape c) A4,A5

d) None of the above

10. __________________ is the shortcut for printing a document.
a) Ctrl+P

b) Ctrl+R

c) Ctrl+N

d) Ctrl+T

11. ___________________ is the shortcut for the cut command.
a)Ctrl+C

b) Ctrl+X

c)Ctrl+V

d)Ctrl+U
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12. A formula in calc may begin with ______________
a)+

b) -

c)=

d) @

c) Handout

d) Notes

13. Identify the default view in Impress.
a)Normal

b) Slide Sorter

14. __________________ protocol transmits and the means to reliably transmit the message.
a)Telnet

b) FTP

c) TCP/IP

d) HTTP

15. _____________________ administers the domain name registration.
a) ISDN
II

b) DSL

c) URL

d)ICANN

Answer( any 6) of the following(Note: Q.No. 22 is compulsory)

6 x 2=12

16. Write a note on retinal scanner.

Retinal Scanner: This performs a retinal scan which is a biometric technique that
uses unique patterns on a person's retinal blood vessels.(4 x ½ =2)
17. Find 2‟s complement of -2310
Binary equivalent 10111
8 bit form 00010111
1‟s complement 11101000
2‟s complement 11101001

(4 x ½ = 2)

18. List the different types of alignment with their icons and shortcuts.
Listing -1, shortcuts- ½ , Icons – ½
19. Define Operating system with 2 examples.

An Operating System (OS) is a system software which serves as an interface
between a user and a computer.Any 2 examples(Definition: ½ + ½ Eg: ½ + ½ )
20. List all the names of icons in Ubuntu OS.
Search your Computer, Files,Firefox Web browser,LibreOffice Writer, LibreOfficeCalc

, LibreOffice Impress , Ubuntu Software , Amazon , System Settings , Trash
(First 5 icons – 1 m, Next 5 icons – 1m)
21. List out all the software packages available in Open Office.

i. OpenOffice Writer - Word Processor to create text documents
ii. • OpenOffice Calc - Spreadsheet to create worksheets
iii. • OpenOffice Base - Database
iv. • OpenOffice Impress - Presentation software
v. • OpenOffice Draw - Drawing Software
vi. • OpenOffice Formula -Create formula and equations
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(First 4-each 1 mark, next 2 each ½ mark)
22. Write out the action, draw icons and shortcut key using different text formatting shortcuts.

OPERATION
BOLD
ITALICS
UNDERLINE

ACTION
Makes the text
bold
Italicizes the
text
Underlines the
text

SHORTC
UT KEY
Ctrl + B
Ctrl +I
Ctrl +U

Operation – ½ , Action – ½ , shortcut – ½ , icons – ½
23. How can we delete rows and columns in a table?(2 x 1 = 2)

i. Place the insertion pointer in the row or column to be deleted and right-click.
ii. 2. Choose Row→Delete to delete row or Column→Delete to delete a column.
24. List out the different types of software.

1) Application Software 2) System Software (2 x 1 = 2)
III

Answer( any 6) of the following( Q.No. 32 is compulsory)

6 x 3=18

25. Write down the different methods of saving the worksheet.

i. Step 1:File → Save (or) Ctrl + S (or) Click “Save” icon on the standard tool bar.
ii. Step 2: If the spreadsheet has not been saved previously, the Save As dialog box
will appear.
iii. Step 3: Type the name in “File Name” list box. OpenOffice Calc Spreadsheets
are stored with extension .ods by default.
iv. Step 4: Click “Save” button.(1st point ½ + ½ + ½ 2nd point - ½ , 3rd point – ½ ,

4th point – ½ )
26. How can we open a new presentation?
In order to open Impress using Start button, click Start button and select All Programs

→ Open Office → OpenOffice Impress.(2)
27. What is an intranet?

An Intranet is a website used by organizations to provide a place where employees
can access company information (eg policies, procedures, staff, directory, department
info), tools (quick links to common apps, forms etc.) and collaborate them(3)
28. What are hotspots?

Hotspots are sites that offer Internet access over a wireless local area network
(WLAN) by way of a router that then connects to an Internet service provider.
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Hotspots utilize Wi-Fi technology, which allows electronic devices to connect to the
Internet or exchange data wirelessly through radio waves. Hotspots can be phonebased or free-standing, commercial or free to the public.(3)
29. Write a note on scanners.

Scanner: Scanners are used to enter the information directly into the computer’s
memory. This device works like a Xerox machine. The scanner converts any type of
printed or written information including photographs into a digital format, which
can be manipulated by the computer.( 6 x ½ =3)
30. Write about a) Serial port b) Parallel port

c) VGA connector

Serial Port: To connect the external devices, found in old computers.
Parallel Port: To connect the printers, found in old computers.
VGA Connector: To connect a monitor or any display device like LCD
projector.(3x1= 3)
31. Write a note on FIFO process scheduling

FIFO (First In First Out)Scheduling: This algorithm is based on queuing
technique. Technically, the process that enters the queue first is executed first by the
CPU, followed by the next and so on. The processes are executed in the order of the
queue.(3 x 1 = 3)
32. Convert 38210 into binary using Sum of Powers of 2 method.
1011111102 (Only sum of powers method) (3)
33. List out the different disk drive icons.

(i) Hard disk (ii) CD-ROM/DVD Drive (iii) Pen drive (iv) Other removable storage
such as mobile, smart phone, tablet etc., (v) Network drives
(All 5 – 3m, 4 – 2m, 3-1 ½ m, 2- 1 m, 1 – ½ m)
IV.

Answer all the questions in detail

5 x 5 = 25

34. Explain in detail about a) Monitor (or) Touch screen
b) Ink jet printer (or) Bar code reader and QR code reader

(1) Monitor: Monitor is the most commonly used output device to display the
information. It looks like a TV. Pictures on a monitor are formed with picture
elements called PIXELS. Monitors may either be Monochrome which display text or
images in Black and White or can be color, which display results in multiple colors.
There are many types of monitors available such as CRT (Cathode Ray Tube), LCD
(Liquid Crystal Display) and LED (Light Emitting Diodes). The monitor works with
the VGA (Video Graphics Array) card. The video graphics card helps the keyboard
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to communicate with the screen. It acts as an interface between the computer and
display monitor. Usually the recent motherboards incorporate built-in video card.
The first computer monitor was part of the Xerox Alto computer system, which was
released on March 1, 1973.
(OR)
Touch Screen: A touch screen is a display device that allows the user to interact with
a computer by using the finger. It can be quite useful as an alternative to a mouse or
keyboard for navigating a Graphical User Interface (GUI). Touch screens are used
on a wide variety of devices such as computers, laptops, monitors, smart phones,
tablets, cash registers and information kiosks. Some touch screens use a grid of
infrared beams to sense the presence of a finger instead of utilizing touch-sensitive
input.
Inkjet Printers use colour cartridges which combined Magenta, Yellow and Cyan
inks to create color tones. A black cartridge is also used for monochrome output.
Inkjet printers work by spraying ionised ink at a sheet of paper. The speed of Inkjet
printers generaly range from 1-20 PPM (Page Per Minute).They use the technology of
firing ink by heating it so that it explodes towards the paper in bubbles or by using
piezoelectricity in which tiny electric currents controlled by electronic circuits are
used inside the printer to spread ink in jet speed. An Inkjet printer can spread millions
of dots of ink at the paper every single second.
(OR)
Bar Code / QR Code Reader: A Bar code is a pattern printed in lines of different
thickness. The Bar code reader scans the information on the bar codes transmits to
the Computer for further processing. The system gives fast and error free entry of
information into the computer. QR (Quick response) Code: The QR code is the two
dimension bar code which can be read by a camera and processed to interpret the
image (2 ½ + 2 ½ )
Do using signed binary arithmetic a) 2510+3910

(OR)
b) 7310-5410.

a) 25
Conversion to binary – ½
8 bit form – ½
39
Conversion to binary – ½
8 bit form – ½
Addition – ½ Ans:1000000
b) 73
Conversion to binary – ½
5

8 bit form – ½
54
8 bit form – ½
2‟s complement - ½
Addition – ½ Ans:00010011
35. Explain in detail the different types of OS?
Single User Operating Systems

An operating system allows only a single user to perform a task at a time. It is called as a Single
user and single Task operating system. For a user, a task is a function such as printing a
document, writing a file to disk, editing a file or downloading a file etc. MS-DOS is an example
for a single user and single task Operating System.
Multi-user Operating Systems
It is used in computers and laptops that allow same data and applications to be accessed by
multiple users at the same time. The users can also communicate with each other. Windows,
Linux and UNIX are examples for multi-user Operating System.( 2 ½ + 2 ½)
(OR)
Write down all the features of Ubuntu.

 The desktop version of Ubuntu supports all normal software like Windows such as Firefox,
Chrome, VLC, etc.
• It supports the office suite called LibreOffice.
• Ubuntu has in-built email software called Thunderbird, which gives the user access to email
such as Exchange, Gmail, Hotmail, etc.
• There are free applications for users to view and edit photos, to manage and share videos.
• It is easy to find content on Ubuntu with the smart searching facility.
• The best feature is, it is a free operating system and is backed by a huge open source
community.(First 4 features each 1 mark , the next 2 each ½ mark)
36. Explain in detail about paste special in Open office writer.

To use the paste special, select the text and apply move or copy, then at the destination
location,
• Click Edit → Paste Special (or) press Ctrl+Shift+V, or Alt+E+S the Paste Special
dialog box opens
• The Paste Special menu varies depending upon the origin and formatting of the text (or
object) to be pasted.
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• Select DDE (Dynamic Data Exchange) link from the Paste special dialog box.
• Select the type of applicatin and click on the OK button.
• The copied data is pasted into the document with a link. (5 x 1 = 5)
(OR)
How can we change the margins using page style dialog box?

1. Right-click anywhere on the page and select Page from the popup menu and select
page tab of page style dialog box.
2. In the Margins boxes, specify the values for left , right , top and bottom margins.
3. Click on ok button.(2+2+1)
37.

Explain in detail about multiple sorting and its steps.

Multi-sorting data
Step 1: Select Data → Sort
Step 2: Sort dialog box appears. (Refer Figure 7.67)
Step 3: Select the field name (Student name) in which you want to sort from the “sort by”
dropdown list box and then choose order of sorting i.e. Ascending or Descending.
Ascending is the default selection.
Step 4: Select another field name (Group Code) from the “Then by” dropdown list box
and choose the order of sorting to this column.
Step 5: Click “OK” button.(5 x 1 = 5)
(OR)
Differentiate static and dynamic web pages.

Static Web Page
Dynamic Web Page
The content and layout of a web page is The content and layout may change
fixed
during run time
Static Web pages never use databases
Databases is used to generate dynamic
content through queries
Static web pages directly run on the Dynamic web pages runs on the server
browser and do not require any server side application programs and displays
side application program
the results
Static Web pages are easy to develop
Dynamic web page development requires
programming skills
(2+1+1+1)
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38.

Convert 11011012 into decimal, hexadecimal and octal
Ans: 10910,6D10,15510(2+2+1)
(OR)
Explain in detail about RAM.

The main memory is otherwise called as Random Access Memory. This is available in computers
in the form of Integrated Circuits (ICs). It is the place in a computer where the Operating System,
Application Programs and the data in current use are kept temporarily so that they can be accessed
by the computer‟s processor. The smallest unit of information that can be stored in the memory is
called as a bit. The memory can be accessed by a collection of 8 bits which is called as a byte. The
bytes are referred by „B‟. If a computer has 1 megabyte of memory, then it can store 10,48,576
bytes (or characters) of information. [Hence 1MB is 1024KB and 1 KB is 1024 Bytes, So
1024X1024 =10,48,576 Bytes]
RAM is a volatile memory, which means that the information stored in it is not permanent. As soon
as the power is turned off, whatever data that resides in RAM is lost. It allows both read and write
operations.
Types of RAM
There are two basic types of RAM
• Dynamic RAM (DRAM)
• Static RAM (SRAM)
These two types differ in the technology they use to hold data. Dynamic RAM being a common
type needs to be refreshed frequently. Static RAM needs to be refreshed less often, which makes it
faster. Hence, Static RAM is more expensive than Dynamic RAM. (RAM-3,Types of RAM – 2 m)

********
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